wp-plugin : gbteamstats – A3-Cross-Site Scripting (XSS)

 

Plugin Details

 

Plugin Name : gbteamstats

 

Effected Version : 1.5.1 (and most probably lower version's if any)

 
Vulnerability : A3-Cross-Site Scripting (XSS)
 
Identified by : Anant Shrivastava

 

 

Technical Details

 

Minimum Level of Access Required : Unauthenticated

 

PoC - (Proof of Concept) :

 
http://localhost/wp-content/plugins/gbteamstats/admin/process-links.php?data=<script>alert(document.cookie)</script>

 

Vulnerable Parameter : data

 

Type of XSS : Reflected

 

Disclosure Timeline

 

Vendor Contacted : 2014-01-05

 
Plugin Status : Closed
 
Public Disclosure : July 7, 2014
 
CVE Number : Not assigned yet

 
Plugin Description :
 
GB Team Stats is a plugin to enable competitive gamers whom use wordpress to pull their team stats into their blogs/sites to show off their pwning skills using GameBattles.

= v2.0 Outlook =

I'm not sure what else to add. If you have ideas, please visit (http://www.truimage.net/2008/09/gb-team-stats/) and leave some comments.

Leave a Reply

Your email address will not be published. Required fields are marked *