wp-plugin : immopress – A3-Cross-Site Scripting (XSS)

 

Plugin Details

 

Plugin Name : immopress

 

Effected Version : 0.0.4 (and most probably lower version's if any)

 
Vulnerability : A3-Cross-Site Scripting (XSS)
 
Identified by : Anant Shrivastava

 

 

Technical Details

 

Minimum Level of Access Required : Unauthenticated

 

PoC - (Proof of Concept) :

 
http://localhost/wp-content/plugins/immopress/sdk/Oauth/example/index.php?sig_method=<script>alert(document.cookie)</script>&

 

Vulnerable Parameter : sig_method

 

Type of XSS : Reflected

 

This specific vulnerability is indeed a flaw in oauth sdk php sample code, multiple wordpress plugin were leveraging this same code and hence a parallel disclosure was made: The entry on OSVDB for the same is listed here : http://osvdb.org/show/osvdb/101897

 

Disclosure Timeline

 

Vendor Contacted : 2014-01-05

 
Plugin Status : Closed
 
Public Disclosure : July 7, 2014
 
CVE Number : Not assigned yet

 
Plugin Description :
 
Erlaubt den einfachen Expose-Import von Immobilienscout24.de in WordPress.

Leave a Reply

Your email address will not be published. Required fields are marked *